Вики IT-KB

Пошаговые руководства, шпаргалки, полезные ссылки...

Инструменты пользователя

Инструменты сайта


cisco:cisco-ios-how-to-create-and-edit-vlan

Cisco IOS - Как настроить VLAN

Посмотреть текущую конфигурацию, в том числе название интерфейсов:

SW01# show running-config

Посмотреть статус конкретного порта:

SW01# show interface GigabitEthernet1/0/21

Перейти в режим настройки конкретного порта:

SW01# configure terminal
SW01(config) # interface GigabitEthernet1/0/21
SW01(config-if) #

Удалить какую-либо настройку старой конфигурации на конкретном порте:

SW01(config-if)# no <конкретная полная строка конфигурации порта>

Далее выбираем для порта один из двух режимов - access mode или trunk mode. Настраиваем порт на режим доступа к одному конкретному VLAN (access mode) Переключить порт в режим доступа (access mode):

SW01(config-if)# switchport mode access

Задать номер VLAN для порта:

SW01(config-if)# switchport access vlan 100

Примечание: Если указываемый VLAN ранее не был описан в конфигурации, то он будет создан.

Настраиваем порт как транковый (возможен доступ как к нескольким VLAN-ам) (trunk mode)

SW01(config-if)# switchport trunk allowed vlan add 120

Добавить описание к порту:

SW01(config-if)# description Server VM10 (Port 3)

В конце настройки не забываем выйти из режима конфигурации интерфейса и сохранить изменения:

SW01(config-if)# exit
SW01(config)# exit
SW01# write
Building configuration...
[OK]

Простой практический пример.

Имеем простенький 24-портовый коммутатор Cisco 2950, на котором нужно создать VLAN и добавить в него пару портов. Создание VLAN'а с идентификатором 150 и задание имени для него:

SW01# configure terminal
SW01(config)# vlan 150
SW01(config-vlan)# name Printers

Просмотр информации о VLAN'ах и распределении портов по этим VLAN-ам:

SW01# show vlan brief

Вывод команды будет примерно таким:

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/4
 Fa0/5, Fa0/6, Fa0/7, Fa0/8
 Fa0/9, Fa0/10, Fa0/11, Fa0/12
 Fa0/13, Fa0/14, Fa0/15, Fa0/16
 Fa0/17, Fa0/18, Fa0/19, Fa0/20
 Fa0/21, Fa0/22, Fa0/23, Fa0/24
 Gi0/2
150 Printers active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

Добавлять порты в VLAN можно по одному. Назначение одного порта коммутатора в VLAN:

SW01(config)# interface Fa0/1
SW01(config-if)# switchport mode access
SW01(config-if)# switchport access vlan 150

…или указав сразу диапазон портов. Назначение диапазона портов с Fa0/1 до Fa0/2 в vlan 150:

SW01(config)# interface range Fa0/1 - 2
SW01(config-if-range)# switchport mode access
SW01(config-if-range)# switchport access vlan 150

Настройка транка (trunk) на аплинковом порте (разрешаем все VLAN-ы):

SW01(config)# interface Gi0/1
SW01(config-if)# switchport mode trunk

Не забываем сохранить изменения :)

SW01(config-if)# exit
SW01(config)# exit
SW01# write

Дополнительные источники информации:

Обсуждение

Ваш комментарий:
 

cisco/cisco-ios-how-to-create-and-edit-vlan.txt · Последние изменения: 03.12.2016 21:16 — Алексей Максимов