Вики IT-KB

Пошаговые руководства, шпаргалки, полезные ссылки...

Инструменты пользователя

Инструменты сайта


cisco:configure-portchannel-link-for-isl-trunk-between-two-hp-storageworks-sn6000c-cisco-mds-9148-fc-switches-nx-os-5

Настройка агрегированного линка PortChannel для ISL Trunk между двумя коммутаторами HP StorageWorks SN6000C FC Switch (Cisco MDS 9148) с NX-OS 5.2

Для того, чтобы улучшить пропускную способность транка Inter-Switch Link (ISL) Trunk между коммутаторами Cisco MDS можно выполнить агрегацию двух и более линков ISL Trunk с помощью PortChannel. Рассмотрим пример настройки такого агрегированного линка, состоящего из двух физических линков между коммутаторами HP StorageWorks SN6000C FC Switch AW585A (Cisco MDS 9148 Multilayer Fabric Switch) с прошивкой NX-OS 5.

В рассматриваемом примере первый коммутатор SW01 уже представляет собой работающую фабрику с настроенным зонированием и к нему подключается дополнительный коммутатор SW02.


Первичная настройка коммутаторов

Установим в стойку и выполним первичную настройку (setup) второго коммутатора, который мы будем подключать к первому, но физическими линками пока не будем подключать второй коммутатор к первому.

Предполагается, что на первом коммутаторе создан уникальный VSAN (отличный от дефолтного VSAN 1), который в дальнейшем будет общим для двух соединённых коммутаторов. В нашем примере таким VSAN будет VSAN 2. Все активные порты первого коммутатора (1-16 порт) включены в VSAN 2.

Посмотрим информацию о VSAN на первом коммутаторе:

SW01# show vsan
SW01# show vsan membership

На втором коммутаторе в полной аналогии с первым создадим VSAN 2 с таким же именем «Production». О том, как создавать VSAN мы говорили в статье про зонирование. Отличием на SW02 будет то, что VSAN 2 может быть в состоянии down, так как к его портам пока может быть ничего не подключено.

Назначим на втором коммутаторе нужные порты в созданный VSAN. В нашем случае в VSAN 2 на втором коммутаторе, так же, как и на первом, включаются все активные порты (с 1 по 16).


Соединяем коммутаторы

Создадим физическое подключение пары любых портов с помощью оптических патч-кордов на первом и втором коммутаторе. В нашем примере используются порты fc1/1 и fc1/2

Посмотрим статус портов и убедимся в том, что на обоих коммутаторах порты перешли в режим транка

# show interface brief


Создаем PortChannel на первом коммутаторе

Создаем агрегированный интерфейс port-channel, например, с номером «1» на первом коммутаторе. Выставляем режим интерфейса в «E» (E_Port/Expansion port). Режим транка включаем в явном виде (on). Прописываем VSAN, которые могут транслироваться через транк. Включаем интерфейс.

SW01# configure terminal
SW01(config)# interface port-channel 1
SW01(config-if)# switchport mode E
SW01(config-if)# switchport rate-mode dedicated
SW01(config-if)# switchport trunk mode on
SW01(config-if)# switchport trunk allowed vsan 1
SW01(config-if)# switchport trunk allowed vsan add 2
SW01(config-if)# no shutdown
SW01(config-if)# exit

Добавляем интерфейсы физических портов fc1/1 и fc1/2 коммутатора в созданный агрегированный линк channel-group 1

SW01(config-if)# interface fc1/1-2
SW01(config-if)# channel-group 1 force

Получим предупреждение о том, что добавленные в группу интерфейсы выключены и должны быть повторно включены. Пока оставляем эти порты выключенными. Включим эти порты позже, когда настроим port-channel на втором коммутаторе.

Посмотрим итоговую конфигурацию группового интерфейса

SW01(config-if)# exit
SW01# show run int port-channel 1

Посмотрим, как выглядят включённые в группу и настроенные интерфейсы

SW01# show running-config interface fc1/1-2

Теперь переходим к настройке на второй коммутатор.


Создаем PortChannel на втором коммутаторе

По аналогии с первым коммутатором создаем агрегированный интерфейс port-channel, например, с номером «1» на втором коммутаторе. Выставляем режим интерфейса в «E» (E_Port/Expansion port). Режим транка, согласно рекомендации из документа HP C-Series Fabric Switches - How does Trunking Work, выставляем в автоматический (auto). Прописываем VSAN, которые могут транслироваться через транк. Включаем интерфейс.

SW02# configure terminal
SW02(config)# interface port-channel 1
SW02(config-if)# switchport mode E
SW02(config-if)# switchport rate-mode dedicated
SW02(config-if)# switchport trunk mode auto
SW02(config-if)# switchport trunk allowed vsan 1
SW02(config-if)# switchport trunk allowed vsan add 2
SW02(config-if)# no shutdown
SW02(config-if)# exit

Добавляем интерфейсы физических портов fc1/1 и fc1/2 коммутатора в channel-group 1

SW02(config-if)# interface fc1/1-2
SW02(config-if)# channel-group 1 force
SW02(config-if)# no shutdown
SW02(config-if)# exit

Так же, как и на первом коммутаторе, здесь мы получим предупреждение о том, что добавленные в группу интерфейсы выключены и должны быть повторно включены. Сейчас мы включаем эти порты:

SW02(config)# interface fc1/1-2
SW02(config-if)# no shutdown
SW02(config-if)# end


Включаем порты на первом коммутаторе

Включим ранее выключенные на первом коммутаторе порты

SW01(config)# interface fc1/1-2
SW01(config-if)# no shutdown
SW01(config-if)# end


Проверяем агрегированный транк

Проверяем состояние интерфейсов, входящих в транк на обоих коммутаторах

SW01# show interface fc1/1
SW01# show interface fc1/2

Кстати, обратите внимание на то, что транковые порты, входящие в группу port-channel автоматически перемещаются в VSAN 1

SW01# show interface port-channel 1

Как видим, транковый агрегированный интерфейс даёт нам 16G линк из двух 8G физических линков между коммутаторами.

Если интерфейс port-channel не поднимается, можем попробовать выключить и снова включить интерфейсы-участники на обоих коммутаторах:

SW02# configure terminal
SW02(config)# interface fc1/1-2
SW02(config-if)# shutdown
SW02(config-if)# no shutdown
SW02(config-if)# end
SW01# configure terminal
SW01(config)# interface fc1/1-2
SW01(config-if)# shutdown
SW01(config-if)# no shutdown
SW01(config-if)# end


Сохраняем конфигурацию

После того, как агрегированный линк между коммутаторами заработал, не забываем сохранить на обоих коммутаторах конфигурацию

SW01# copy running-config startup-config
SW02# copy running-config startup-config

В качестве альтернативы на любом из коммутаторов можно выполнить команду сохранения конфигурации для всех коммутаторов в фабрике:

SW01# copy running-config startup-config fabric


Трансляция зонирования между коммутаторами

Проверяем то, что на втором подключенном коммутаторе доступны псевдонимы Device Alias, ранее созданные на первом коммутаторе.

SW02# show device-alias database

Проверяем то, что на втором подключенном коммутаторе доступна информация об активном наборе зон в нашем продуктивном VSAN 2. То есть то, что мы ранее создавали на первом коммутаторе.

SW02# show zoneset active


Полная передача зон между коммутаторами

Мы проверили и убедились в том, что через созданный нами транк с первого коммутатора на второй транслируется информация об псевдонимах device-alias и активном наборе зон в нашем продуктивном VSAN 2. Однако, если на коммутаторах не включена передача всех наборов зон (а не только активных), то на втором коммутаторе мы не сможем увидеть информацию о созданных ранее на первом коммутаторе зонах и наборах зон. В этом случае вывод команд, перечисляющих зоны и наборы зон на втором коммутаторе, будет выглядеть так:

SW02# show zone
SW02# show zoneset

А так выглядит вывод этих же команд на первом коммутаторе, то есть там, где эти зоны и наборы зон изначально создавались:

Связано это с тем, что в конфигурации по умолчанию в Cisco MDS между коммутаторами фабрики передаётся информация только о конечном активном наборе зон в VSAN. Подтверждение этому можно получить, перечислив информацию о VSAN

SW01# show zone status vsan 2

Для того, чтобы информация о всех созданных зонах была нам доступна на обоих коммутаторах фабрики, нам потребуется включить режим распространения полного набора зон - Full Zone Set Distribution. Сразу после включения активируем повторно набор зон.

SW01# configure terminal
SW01(config)# zoneset distribute full vsan 2
SW01(config)# zoneset activate name ActiveZoneSet vsan 2
SW01(config)# end
SW01# copy running-config startup-config

Сохраним настроенную конфигурацию и снова проверим информацию о зонах в нашем продуктивном VSAN 2

SW01# show zone status vsan 2

Как видим, теперь на первом коммутаторе зоны из VSAN 2 распространяются полностью.

Выполним те же конфигурационные изменения на втором коммутаторе:

SW02# configure terminal
SW02(config)# zoneset distribute full vsan 2
SW02(config)# zoneset activate name ActiveZoneSet vsan 2
SW02(config)# end
SW02# copy running-config startup-config
SW02# show zone status vsan 2

Теперь снова проверим на втором коммутаторе список зон и наборов зон, созданных ранее на первом коммутаторе и убедимся в том, что теперь они отображаются в таком же виде, как на первом коммутаторе:

SW02# show zone
SW02# show zoneset

Теперь можно на любом из коммутаторов настраивать зоны в нашем продуктивном VSAN и иметь перед глазами всю картину по зонированию в целом.


Дополнительные источники информации:


Проверено на следующих конфигурациях:

Модель коммутатора Версия ОС коммутатора
Cisco MDS 9148 Multilayer Fabric Switch DS-C9148-16P-K9 V02
HP StorageWorks SN6000C FC Switch AW585A
Cisco NX-OS 5.2(8d)

Автор текущей редакции:
Алексей Максимов
Время публикации: 12.04.2019 15:05

Обсуждение

Ваш комментарий:
 

cisco/configure-portchannel-link-for-isl-trunk-between-two-hp-storageworks-sn6000c-cisco-mds-9148-fc-switches-nx-os-5.txt · Последние изменения: 12.04.2019 17:17 — Алексей Максимов