Вики IT-KB

Пошаговые руководства, шпаргалки, полезные ссылки...

Инструменты пользователя

Инструменты сайта


vocord:vocord-phobos-sql-server-upgrade-to-2008-r2-sp3-version

Обновление экземпляра Microsoft SQL Server серверной части ПО Vocord PHOBOS до уровня SQL Server 2008 R2 Express Edition Service Pack 3 (32-bits)

Если вы используете устаревшие платы аудиозаписи, такие как Phobos A4/A8/D4/D8, то уже наверняка знаете, что производитель плат не предоставляет драйверов для этих плат под 64-битную платформу Windows. Это накладывает свои ограничения на максимально возможный уровень обновления серверных систем с ПО Vocord PHOBOS, так как выпуск 32-битных серверных ОС Windows был прекращён начиная с версии Windows Server 2008. Таким образом, максимальный уровень обновления серверных систем с ПО Vocord PHOBOS - это уровень Windows Server 2008 32-bits Service Pack 2.

Если вы ещё не обновили операционные системы серверов Phobos до этого уровня, то для этого ещё есть время, так как расширенная поддержка операционной системы Windows Server 2008 32-bits действует до 14 Января 2020 года. Это означает, что обновления безопасности этой версии ОС будут выпускаться компанией Microsoft только до этой даты. Ну а начиная с даты окончания срока расширенной поддержки, нужно будет решать вопрос о смене технологического решения использующего указанные платы на какое-то альтернативное, так как необновляемая серверная система может стать серьёзной брешью в корпоративной системе безопасности.

12 Апреля 2016 года закончился цикл расширенной поддержки всех версий SQL Server 2005. Опять таки это означает, что начиная с этой даты компанией Microsoft прекращён выпуск обновлений безопасности данного серверного продукта. Таким образом, если вы ещё имеете в продуктивной среде использование экземпляров этой версии, то необходимо выполнить процедуру перехода имеющихся экземпляров SQL Server 2005 на более новые версии.

Применительно к Vocord PHOBOS нужно отметить тот факт, что по умолчанию это ПО при установке использует вообще экземпляр версии SQL Server 2000, который снят с расширенной поддержки ещё в 2013 году.

Учитывая наш опыт эксплуатации ПО Vocord PHOBOS можно сказать, что сервер аудиозаписи с этим ПО вполне можно обновить до приемлемого, с точки зрения безопасности, на сегодняшний день уровня:

  • Операционная система Microsoft Windows Server 2008 32-bits Service Pack 2
  • СУБД Microsoft SQL Server 2008 R2 Express Edition 32-bits Service Pack 3

В рамках данной статьи мы дадим ряд комментариев, которые нужно учитывать в процессе обновления экземпляра Microsoft SQL Server серверной части ПО Vocord PHOBOS до уровня SQL Server 2008 R2 SP3 Express Edition 32-bits.

Для начала проверим версию Phobos Server, для этого запустим:

C:\Program Files\Vocord Telecom\Phobos System\PhobosVer.exe

Желательно иметь версию не ниже 2.2.15.225.

Для поиска и загрузки новых версий ПО Vocord PHOBOS можно использовать публичный FTP сервер компании Вокорд:

ftp://ftp.vocord.ru/priv/nick/ASO/demin/Phobos/

Начиная с версии 2.2.16.260 требуется .Net Framework 4.5. Но если вы используете платы перечисленные в начале этой статьи, то в установке более новой версии, чем 2.2.15.225 смысла нет, так как новые версию лишь добавлены компоненты для новых устройств Вокорд, которых у вас нет.

Дистрибутив версии Vocord PHOBOS 2.2.15 можно найти в Архиве

Наличие версии Vocord PHOBOS не ниже 2.2.15 - это важный момент, так как на старых версиях сервера были замечены проблемы совместимости с Microsoft SQL Server 2008.

Если у вас используется версия более старая, чем 2.2.15, выполните её обновление:

  1. 1. Удалите текущую версию клиента и сервера;
  2. 2. Установите более новую версию без пересоздания базы данных.

После того, как Vocord PHOBOS приведён к версии 2.2.15, можно выполнить обновление экземпляра SQL Server.

Загружаем дистрибутив Microsoft SQL Server 2008 R2 SP2 - Express Edition

Останавливаем службы Phobos командой:

net stop PhNotifyServ && net stop vtjeserver

Запускаем установщик SQL Server 2008 R2 SP2 Express Edition и выбираем обновление:

Процесс обновления сложностей вызвать не должен. Несколько раз нажимаем «Далее» и готово. По окончании процесса - перезагрузка сервера.

После перезапуска первым делом нужно убедиться в том, что база данных PH работает в режиме совместимости SQL Server 2005.

После этого проверяем работоспособность системы, выполняя базовые операции:

  • Подключение клиентом Phobos к серверу
  • Создание/изменение/удаление пользователя на сервере Phobos
  • Появление новых записей переговоров
  • Прослушивание записей
  • Экспорт записей.

После того, как всё проверено и работоспособность ПО Vocord PHOBOS подтверждена, необходимо будет дополнительно обновить экземпляр SQL Server 2008 R2 SP2 Express Edition до уровня Service Pack 3 (SP3). Вы можете загрузить отдельный пакет обновления Microsoft SQL Server 2008 R2 Service Pack 3 и выполнить его установку:

Разумеется после этого обновления также желательно проверить работоспособность системы Phobos, выполняя ранее перечисленные базовые операции.

На этом всё.
Удачных обновлений!


Автор первичной редакции:
Алексей Максимов
Время публикации: 03.06.2016 15:04

Обсуждение

Ваш комментарий:
 

vocord/vocord-phobos-sql-server-upgrade-to-2008-r2-sp3-version.txt · Последние изменения: 05.06.2016 09:09 — Алексей Максимов